Matt Greencroft has his say

Matt's Blog

Tomcat problems with Java 8

23-Aug-2016 in Errata Core Java Web Development

If you're doing any of our courses that use Tomcat, be aware that the latest update to Java 8 (1.8.0_91) seems to have broken JSP compilations for all versions of Tomcat up to and including 8. We're not sure why this is happening, but as a quick fix either use Java 1.8.0_77 or earlier, OR use Tomcat 9 which is confirmed to fully support Java 8.

(Note that Tomcat 9 is still in Alpha, so doing this carries some risk - the safest choice is to use an earlier Java).

Thanks to all those who have reported this, and you can also follow a Stackoverflow post at https://stackoverflow.com/questions/36956912/spring-mvc-unable-to-compile-class-for-jsp

Listen via:


About Matt

I'm a Java developer and trainer for Virtual Pair Programmers, where I present video based training courses on Java, Spring and associated frameworks. I'm currently working on a few different web projects.


Be notified of new posts